Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2025 - 22:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Wednesday, June 23rd, 2025, for 15 minutes, between 23:00 BST and 23:15 BST. (18:00 EDT and 18:15 EDT). (08:00 AEST and 08:15 AEST on June 23rd).
The service may be unavailable during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l'objet d'une maintenance système importante le Mercredi 23 Juin, 2025, pendant 15 minutes, entre 18:00 EDT et 18:15 EDT.
Le service peut être indisponible pendant cette période prévue.
Nous nous excusons pour les inconvénients que cela pourrait causer.
Merci. L'équipe Sage.
Posted Jun 18, 2025 - 15:32 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).