Sage HR - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Apr 10, 2025 - 13:01 UTC

Update

We have identified an issue where customers and employees in Canada have lost their ability to view pay slips in Sage HR despite having their company synced with Sage 50.
We are currently investigating.
Posted Apr 09, 2025 - 20:11 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 09, 2025 - 18:55 UTC
This incident affected: North America (Sage HR).