My Sage - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Jan 12, 2026 - 16:36 UTC

Investigating

We have identified that customers in the UK and Ireland are unable to see their invoices from 2019 and later in My Sage. All other product functionality is working as expected.

We are currently investigating.
Posted Jan 12, 2026 - 09:57 UTC
This incident affected: Europe (My Sage).