Sage HR - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved, and the service is available and performing as expected.
Posted Jun 22, 2025 - 12:39 UTC

Update

We have identified an issue impacting users globally. Customers may experience slowness when taking actions, or will be presented with 500 errors when using the product.

We are currently investigating.
Posted Jun 22, 2025 - 11:23 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 22, 2025 - 11:09 UTC
This incident affected: South America (Sage HR), Middle East and Africa (Sage HR), Asia Pacific (Sage HR), North America (Sage HR), and Europe (Sage HR).