The incident is now resolved. The service is currently performing as expected.
Posted Aug 20, 2025 - 15:52 UTC
Identified
We have identified the cause of the issue, and we are working on a fix to resolve it.
Thank you for your patience as we work to resolve this issue.
Posted Aug 19, 2025 - 16:07 UTC
Update
We identified an issue affecting a subset of customers in the US from creating sites for Sage 50 US, while existing sites remain unaffected. All other product functionalities are working as expected.
We are currently investigating.
Posted Aug 19, 2025 - 12:38 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 19, 2025 - 12:02 UTC
This incident affected: North America (Sage 50 Hosted).