The issue is resolved and the service continues to perform as expected.
Posted Sep 14, 2026 - 07:06 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Sep 13, 2026 - 20:57 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 13, 2026 - 20:03 UTC
Identified
We have identified an issue where customers in North America, Spain and France are prevented from accessing the service. Customers in North America are however able to access the service using the windows mode while customers in Spain can access the service using the launcher.