Sage.com Websites - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Nov 05, 2025 - 16:17 UTC

Monitoring

The service is performing as expected. Avoiding a re-occurrence is our priority as we closely monitor the service.
Posted Nov 05, 2025 - 02:16 UTC

Update

We are continuing to investigate the cause of the issue. We appreciate your patience as we work to resolve this issue
Posted Nov 05, 2025 - 01:02 UTC

Update

We have identified an issue where customers globally cannot access the Sage.com website. Customers are presented with 504 error message when accessing the site. We are currently investigating.
Posted Nov 04, 2025 - 23:53 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Nov 04, 2025 - 23:07 UTC
This incident affected: South America (Sage.com Websites), Middle East and Africa (Sage.com Websites), Asia Pacific (Sage.com Websites), North America (Sage.com Websites), and Europe (Sage.com Websites).