Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2026 - 04:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Friday, May 8th, 2026, for 7 hours, between 00:00 EDT and 07:00 EDT. (05:00 BST and 18:00 BST); (14:00 AEDT and 21:00 AEDT)
The service may be unavailable for a few minutes during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l’objet d’une maintenance le vendredi 8 mai, 2026, pour une durée de 7 heures, entre 00:00 EDT et 07:00 EDT le 23 avril.
Le service pourrait être indisponible pendant quelques minutes durant cette période planifiée.
Nous nous excusons pour les inconvénients que cela pourrait causer.
Merci. L’équipe Sage
Posted May 06, 2026 - 16:50 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).