The issue is now resolved. The service is currently performing as expected. Customers can now sign up for an HR trial on Sage.com.
Posted Sep 02, 2025 - 10:26 UTC
Update
We identified an issue affecting a subset of customers in Europe and North America who are trying to sign up for an HR trial on Sage.com. Customers are encountering an incorrect redirect when attempting to submit the form. All other product functionality is working as expected.
We are currently investigating.
Posted Sep 02, 2025 - 09:43 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 02, 2025 - 09:24 UTC
This incident affected: North America (Sage.com Websites) and Europe (Sage.com Websites).