Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2022 - 16:30 UTC
Scheduled
There is planned maintenance scheduled with our third-party HMRC on Making Tax Digital this weekend. Due to scheduled maintenance, you will be unable to access the following services: MTD VAT Making Tax Digital customers will be unable to submit VAT returns between 16:30 UTC on Saturday 14th May to 22:15 UTC on Saturday 14th May.
Posted May 10, 2022 - 13:12 UTC
This scheduled maintenance affected: Europe (Compliance Service, Service Fabric - Tax Services).