Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 18, 2025 - 22:00 UTC
Scheduled
Brightpearl Europe will be undergoing maintenance on Tuesday, February 18th, 2025, for 30 minutes, between 22:00 UTC and 22:30 UTC ( 23:00 CET and 23:30 UTC).
The service may be unavailable for a short period during this time.
We apologize for any inconvenience this may cause.
Thank you.
The Sage Team
Posted Feb 13, 2025 - 08:24 UTC
This scheduled maintenance affected: Europe (Brightpearl).