Sage Business Cloud Financials - Major Outage
Incident Report for Sage
Resolved
The issue affecting Sage Business Cloud Financials has now been resolved. We apologise for any inconvenience caused.
Posted May 07, 2020 - 15:04 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 07, 2020 - 14:33 UTC
This incident affected: Europe (Sage Business Cloud Financials).