Sage Business Cloud Payroll Professional - Major Outage
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Mar 20, 2023 - 09:47 UTC
Update
We identified an issue preventing customers from South Africa from accessing SBC Payroll Professional.

We are currently investigating.
Posted Mar 20, 2023 - 08:50 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 20, 2023 - 08:32 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Payroll Professional).