Sage People - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.

If you are facing issues when accessing the service, please follow the below steps:

Go to Setup > My Domain, under Redirections click Edit and check the boxes as follows -

Redirect legacy (non-enhanced) My Domain hostnames
Maintain legacy redirections during the Winter '26 upgrade
Log redirections

Click Save

For further information please click on this link.
Posted Jun 12, 2025 - 15:32 UTC

Monitoring

We have identified an issue preventing a subset of global customers from logging Sage People. The service is available and performing as expected for the majority of customers.
If you are facing issues when accessing the service, please follow the below steps:

Go to Setup > My Domain, under Redirections click Edit and check the boxes as follows -

Redirect legacy (non-enhanced) My Domain hostnames
Maintain legacy redirections during the Winter '26 upgrade
Log redirections

Click Save

For further information please click on this link.
Posted Jun 09, 2025 - 10:19 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 09, 2025 - 09:51 UTC
This incident affected: South America (Sage People), Middle East and Africa (Sage People), Asia Pacific (Sage People), North America (Sage People), and Europe (Sage People).