Sage Business Cloud Payroll - Degraded Performance
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.

If you have identified that your payslip emails were not sent, you can resend them manually from the UI. You can find detailed instructions in the following link.
Posted Sep 16, 2024 - 10:07 UTC
Update
We identified that customers' payslips emails are not being sent for UK customers.

We are currently investigating.
Posted Sep 16, 2024 - 08:10 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 16, 2024 - 07:54 UTC
This incident affected: Europe (Sage Business Cloud Payroll).