The issue is resolved and the service is available and performing as expected.
Posted Apr 17, 2026 - 17:38 UTC
Update
We are continuing to investigate. We appreciate your patience as we work to resolve this issue.
Posted Apr 17, 2026 - 16:02 UTC
Update
We have identified an issue preventing a small subset of customers in the UK from downloading transactions via Banking services. So far, we are that customers using NatWest, UniCredit, Bank GmbH, HSBC and Metro Banks are impacted. We are currently investigating.
Posted Apr 17, 2026 - 11:08 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.