The incident is now resolved. We have received the file with the missing transactions from cashplus Bank (Europe) and we can confirm that all transactions from the 7th of March are included.
Posted Mar 10, 2023 - 17:58 UTC
Update
We have received one of the files with the missing transactions from Cashplus Bank and we can confirm that all transactions from March 8th are included. We continue to be engaged with our third party, Cashplus Bank, who is currently working to manually generate the other file with the March 7th transactions.
Posted Mar 10, 2023 - 12:41 UTC
Identified
We identified an issue in Europe preventing Cashplus Bank customers from receiving their transactions. As a result, a proportion of customers using Cashplus Bank will experience delays getting their transactions from the 7th and 8th of March. We are engaged with our third-party Cashplus Bank to resolve this issue.