The issues with our email provider are now resolved and emails are being sent as expected.
Posted Jan 23, 2026 - 06:55 UTC
Update
Our email provider has identified the cause of the issue and is working on a fix.
Posted Jan 22, 2026 - 22:59 UTC
Identified
We have identified an issue where customers in NA are not receiving emails after submitting a password reset. Our email provider is working on a resolution.
Posted Jan 22, 2026 - 21:47 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.