Sage Expense Management - Degraded Performance

Incident Report for Sage

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Nov 04, 2025 - 12:02 UTC

Update

We have identified an issue impacting customers in the USA and Europe. Customer are facing slowness.
We are currently investigating.

The products/services affected are:
-Sage Expense Management
-Sage Expense Management Mobile
-Sage Expense Management API
Posted Nov 04, 2025 - 10:34 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Nov 04, 2025 - 10:22 UTC
This incident affects: North America (Sage Expense Management, Sage Expense Management API, Sage Expense Management Mobile).