Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 15, 2025 - 18:30 UTC
Scheduled
Sage 300 People Managed Services will undergo essential system maintenance on Friday, 15 August 2025 for 30 minutes between 20:30 SAST and 21:00 SAST.
Please note that you may experience service interruptions connecting to ESS or API Integrations during this time. Access to the Sage 300 People application will remain accessible during this time.
We apologize for any inconvenience caused.
Thank you for your patience. The Sage Team.
Posted Aug 15, 2025 - 09:14 UTC
This scheduled maintenance affected: Middle East and Africa (Sage 300 People Managed Services).