My Sage - Full Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Feb 04, 2025 - 09:26 UTC

Investigating

Customers may experience loading issues when logging into or navigating My Sage.

We are currently investigating
Posted Feb 03, 2025 - 10:06 UTC
This incident affected: Europe (My Sage).