Sage Construction Management - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Oct 31, 2025 - 16:14 UTC

Identified

We’ve recently updated the login URL for Sage Construction Management. Due to a notification delivery issue, some customers may not have received the original communication.

To ensure uninterrupted access, please use the new login URL below:
Sage Construction Management Login.

We apologize for any inconvenience and appreciate your understanding.

If you have any questions or experience issues with your access, please contact your local customer services team.
Posted Oct 30, 2025 - 16:04 UTC
This incident affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).