PAYA Payment Center - Degraded Performance
Incident Report for Sage
Resolved
The issue now has been resolved.
We apologise for any inconvenience caused.
Posted May 29, 2020 - 11:42 UTC
Monitoring
We continue to investigate the issues some customers have reported with the Paya service. We will update once we have a resolution to this issue. We apologise for any inconvenience this may be causing.
Posted May 27, 2020 - 18:05 UTC
Identified
We have received report from our partner Paya about a sporadic issue in which customers are not able to complete their login process (encountering timeouts) when submitting payments to payment centre.

We are currently working to resolve the issue.
Posted May 23, 2020 - 12:38 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 22, 2020 - 18:06 UTC
This incident affected: North America (PAYA Payment Center).