Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 29, 2025 - 23:30 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Wednesday, October 29th, 2025, for 8 hours, between 23:30 UTC and 07:30 UTC on October 30th . (19:30 EDT on October 29th and 03:30 EDT on October 30th). (10:30 AEDT and 18:30 AEDT on October 30th).
The service may be unavailable for 15 minutes anytime this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management subira une maintenance le mercredi 29 octobre, 2025, pour 8 heures, entre 19:30 EDT et 03:30 EDT le 30 octobre).
Le service pourrait être indisponible pendant 15 minutes à tout moment à cette heure.
Nous vous prions de nous excuser pour la gêne occasionnée.
Merci. L'équipe Sage
Posted Oct 24, 2025 - 12:46 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).