My Sage UKI - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Mar 03, 2026 - 16:15 UTC

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service
Posted Mar 03, 2026 - 11:36 UTC

Investigating

We have identified that a subset of customers in the UK and Ireland are receiving notifications to advise that their invoices are available to view, however, when they log in they are not.

We are currently investigating.
Posted Mar 02, 2026 - 10:31 UTC
This incident affected: Europe (My Sage).