Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 04, 2025 - 19:00 UTC
Scheduled
Sage People will be undergoing maintenance on Monday, August 4th, 2025 for 20 minutes between 20:00 BST and 20:20 BST (15:00 EST and 15:20 EST)
The service may be unavailable during this scheduled time
We apologise for any inconvenience this may cause.
Thank you. The Sage Team
Posted Aug 01, 2025 - 07:22 UTC
This scheduled maintenance affected: South America (Sage People), Middle East and Africa (Sage People), Asia Pacific (Sage People), North America (Sage People), and Europe (Sage People).