Sage 50 US / Canada - Partial Outage

Incident Report for Sage

Identified

We continue to investigate, we apologize for any inconvenience this might cause.
Posted May 23, 2025 - 13:01 UTC

Investigating

We have identified that a subset of customers in the US and Canada are unable to reconnect invoice payments. When they attempt, they are presented with the following error message: "Could not connect to the reCAPTCHA service."
The following services are affected:

-Sage 50 US
-Sage 50 Canada

We are currently investigating.
Posted May 21, 2025 - 21:36 UTC
This incident affects: North America (Sage 50).