Sage.com Websites - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Mar 17, 2026 - 11:40 UTC

Monitoring

We identified an issue that prevented customers globally from accessing sage.com website. Customers attempting to access the site were presented with a "maintenance page". The service is now restored and Sage.com website is accessible and performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Mar 17, 2026 - 03:23 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 17, 2026 - 02:50 UTC