Sage Intacct - Partial Outage

Incident Report for Sage

Resolved

The incident is now resolved. The service is currently performing as expected.
Posted Mar 27, 2025 - 06:13 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 27, 2025 - 05:47 UTC
This incident affected: North America (Sage Intacct).