Sage Intacct - Partial Outage

Incident Report for Sage

Resolved

We identified an issue preventing a small subset of customers in the US from accessing the service.

The issue is resolved, and the service is performing as expected.
Posted May 05, 2025 - 20:50 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 05, 2025 - 20:35 UTC
This incident affected: North America (Sage Intacct).