Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 29, 2022 - 16:00 UTC
Scheduled
Due to scheduled maintenance from HMRC, you will be unable to access the following services:
MTD ITSA - from 4:00pm UTC on Friday 29 July to 8:00am UTC on Monday 1 August. MTD VAT - from 7:15am UTC on Sunday 31 July to 6.00pm UTC on Sunday 31 July.
We apologise for any inconvenience this may cause.
Posted Jul 28, 2022 - 12:35 UTC
This scheduled maintenance affected: Europe (Making Tax Digital (MTD), Tax Service).