We continue working on a fix for the issue. As workaround the customers are able to onboard each bank account separately.
Posted Jun 04, 2026 - 11:03 UTC
Identified
We have identified that customers in the US using Sage Intacct are unable to connect multiple bank accounts at once (multi account linking) for some bank connections. All other functionality is performing as expected and the Plaid and SISS connections are unaffected. As workaround the customers are able to onboard each bank account separately. We are currently working on a permanent fix.
Posted May 29, 2026 - 17:28 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 29, 2026 - 16:52 UTC
This incident affects: North America (Banking Service, Sage Intacct).