Sage Intacct - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Mar 17, 2025 - 18:04 UTC

Update

We continue to work on the fix for this issue.
Posted Mar 17, 2025 - 17:02 UTC

Identified

We have identified an issue preventing customers in NA from creating invoices. We have identified the cause of the issue and are working on a fix.
Posted Mar 17, 2025 - 14:56 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 17, 2025 - 14:35 UTC
This incident affected: North America (Sage Intacct).