Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 11, 2025 - 05:00 UTC
Scheduled
Sage Portal will be undergoing system maintenance on Saturday, October 11th, 2025, for 6 hours between 07:00 SAST and 13:00 SAST; (15:00 AEST and 21:00 AEST).
The service will be unavailable during this scheduled time.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Oct 09, 2025 - 15:02 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Portal) and Asia Pacific (Sage Portal).