Sage Construction Management - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Feb 19, 2025 - 20:57 UTC

Monitoring

Between 21:10 UTC and 21:17 UTC on February 18th, we identified an issue affecting customers in North America who were experiencing intermittent login problems with our service. Customers were able to successfully log in by refreshing the page and trying again later.

The issue was restored at 21:17 UTC on February 18th, and the service is currently performing as expected.
Posted Feb 19, 2025 - 16:03 UTC
This incident affected: North America (Sage Construction Management).