My Sage - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Jun 12, 2026 - 16:17 UTC

Update

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Jun 12, 2026 - 13:40 UTC

Investigating

We have identified that customers in the UK are experiencing a variety of errors when attempting to use the service.

We are currently investigating.
Posted Jun 12, 2026 - 11:02 UTC
This incident affected: Europe (My Sage).