The issue is resolved and the service continues to perform as expected.
Posted Feb 25, 2026 - 16:04 UTC
Monitoring
The FPS submissions are now performing as expected.
We will continue to monitor closely.
Posted Feb 25, 2026 - 09:41 UTC
Investigating
We identified that customers in the UK are experiencing delays when attempting to submit FPS as the submissions are getting stuck loading and do not go through.
Products affected by this issue are: - Sage 50 Payroll - Sage Business Cloud Payroll
Posted Feb 24, 2026 - 11:25 UTC
This incident affected: Europe (Sage 50 Payroll, Sage Business Cloud Payroll).