Sage E - Business Invoicing
Incident Report for Sage
Resolved
The connection issue
The connection issue with the Sage Pastel E-business product has been resolved. We will monitor the service to ensure it remains stable.
Posted Jan 12, 2021 - 09:48 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jan 12, 2021 - 09:29 UTC
This incident affected: Middle East and Africa (Sage E-Business Invoicing).