Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2026 - 03:30 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Friday, March 20th, 2026, for 7 hours between 23:30 EDT and March 21st, 2026 10:30 EDT. (03:30 UTC and 10:30 UTC on March 21st); (14:30 AEDT and 21:30 AEDT on March 21st).
The service may be unavailable during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l’objet d’une maintenance le vendredi 20 mars 2026, pour une durée de 7 heures, entre 23 h 30 (HE) et le 21 mars 2026 à 10 h 30 (HE). (21 mars de 03 h 30 à 10 h 30 (UTC); 21 mars de 14 h 30 à 21 h 30 (HAE)).
Le service pourrait être indisponible pendant cette période planifiée.
Nous nous excusons pour tout inconvénient que cela pourrait occasionner.
Merci, L’équipe Sage
Posted Mar 20, 2026 - 15:57 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).