Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 22, 2025 - 01:00 UTC
Scheduled
The National Employment Savings Trust (NEST) Corporation will be undergoing important system maintenance on Saturday, February 22nd, 2025, for 6 hours, between 01:00 UTC and 07:00 UTC.
Customers using the below products/services will be unable to submit Nest during this period of time:
-Employee Verification (UK) -Sage HR (UK) -Sage Business Cloud Payroll (UK) -Sage 50 Payroll (UK) -Pension Data Exchange (UK)
We apologize for any inconvenience this may cause.
Thank you. The Sage Team.
Posted Feb 18, 2025 - 12:05 UTC
This scheduled maintenance affects: Europe (Employee Verification (UK), Pension Data Exchange (UKI), Sage 50 Payroll, Sage Business Cloud Payroll, Sage HR (UK)).