The issue is resolved and the service is available and performing as expected.
Posted Dec 08, 2025 - 17:00 UTC
Update
The release has been successfully updated, and everything is now in place. We will continue to closely monitor its performance through during business hours to ensure stability and confirm that everything is functioning as expected.
Posted Dec 08, 2025 - 12:26 UTC
Identified
We have identified an issue where customers in North America are experiencing performance degradation. We have scheduled maintenance tomorrow, December 6th, from 05:00 UTC to 22:00 UTC, to resolve this issue.
If you are experiencing issues, please swap back to legacy until after the maintenance window.
Posted Dec 05, 2025 - 17:34 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Dec 05, 2025 - 17:06 UTC
This incident affected: North America (Sage Construction Management).