Sage Distribution and Manufacturing Operations (SDMO) - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Mar 17, 2025 - 16:02 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 17, 2025 - 15:42 UTC
This incident affected: Europe (Sage Distribution and Manufacturing Operations (SDMO)).