We continue working on a fix. Thank you for your patience as we work to resolve this issue.
Posted Sep 22, 2026 - 15:52 UTC
Identified
We have identified the cause of the issue and we are working on a fix.
Posted Sep 22, 2026 - 14:12 UTC
Update
We have identified an issue intermittently preventing the creation of new sites and sites that need to be re-provisioned. We are investigating.
The products/services affected are: - Sage 50 Cloud US - Sage 50 Cloud UK - Sage 100 Contractor Cloud US - Sage Fixed Assets Cloud US - Sage BOB
Posted Sep 22, 2026 - 13:23 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 22, 2026 - 12:52 UTC
This incident affects: North America (Sage 50 Cloud (US), Sage 100 Contractor Cloud, Sage Fixed Assets Cloud) and Europe (Sage 50 Cloud (UK), Sage BOB).