Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2026 - 04:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Saturday, May 16th, 2026, for 6 hours, between 00:00 EDT and 06:00 EDT. (05:00 BST and 11:00 BST); (14:00 AEDT and 20:00 AEDT)
The service may be unavailable for a few minutes during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l’objet d’une maintenance le samedi 16 mai, 2026, pour une durée de 6 heures, entre 00:00 EDT et 06:00 EDT.
Le service pourrait être indisponible pendant quelques minutes durant cette période planifiée.
Nous nous excusons pour les inconvénients que cela pourrait causer.
Merci. L’équipe Sage
Posted May 15, 2026 - 19:02 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).