Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2026 - 16:00 UTC
Scheduled
The Subscription Services will undergo maintenance on May 16th, 2026 for 1 hour between 16:00 UTC to 17:00 UTC.
The service may not be available during the scheduled maintenance window.
We apologize for any inconvenience caused.
Thank you for your patience. The Sage Team.
Posted May 12, 2026 - 16:53 UTC
This scheduled maintenance affected: South America (Subscription Services), Middle East and Africa (Subscription Services), Asia Pacific (Subscription Services), North America (Subscription Services), and Europe (Subscription Services).