Sage ESS - Major Outage
Incident Report for Sage
Resolved
The service has been restored and the logon issues are now resolved. If you continue to experience logon issues, please contact our Customer Services team.
Posted Sep 14, 2020 - 03:02 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 14, 2020 - 02:25 UTC
This incident affected: Asia Pacific (Sage ESS).