Please note that if you have downloaded the latest Windows 11 25H2 (Release Known Issues) update you will be unable to log in to Sage 300 People Managed Service using the remote desktop client.
As a workaround, please download the previous version of RDC from this link or use the Microsoft Windows web client.
Posted Jan 19, 2026 - 14:39 UTC
Identified
We have identified that customers who have downloaded the latest Windows 11 25H2 (Release Known Issues) update will be unable to log in to Sage 300 People Managed Service using the remote desktop client.
As a workaround, please download the previous version of RDC from this link or use the Microsoft Windows web client.
Posted Jan 15, 2026 - 13:38 UTC
This incident affected: Middle East and Africa (Sage 300 People Managed Services).