Sage Construction Management - Operational
Incident Report for Sage
Resolved
The issue is resolved. Sage Construction Management continues to perform as expected.
Posted Aug 26, 2024 - 21:52 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Aug 26, 2024 - 18:27 UTC
Update
We identified an issue causing slowness when navigating screens for users in North America. We are currently investigating.
Posted Aug 26, 2024 - 16:38 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 26, 2024 - 16:17 UTC
This incident affected: North America (Sage Construction Management).