Sage 50 / Sage 100 US Direct Deposit - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Nov 04, 2025 - 19:48 UTC

Update

We have identified an issue causing multiple duplicate payroll syncs for customers in North America We are currently investigating the cause of the issue.
Posted Nov 04, 2025 - 18:45 UTC

Investigating

We are detecting possible sync errors and ask customers not to perfom payroll syncs while we investigate.
Posted Nov 04, 2025 - 18:10 UTC
This incident affected: North America (Sage 50 / Sage 100 US Direct Deposit).