Sage Commerce - Partial Outage

Incident Report for Sage

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 14:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2026 - 16:43 UTC

Identified

Thank you for your patience as we work to resolve this issue.
Posted Jun 24, 2026 - 13:47 UTC

Investigating

We have identified an intermittent global issue preventing customers managing subscriptions. Customers are being presented with an error message: "We couldn't process your request". All other product functionalities are performing as expected.
We are investigating.

The products/services affected are:
-Sage For Accountants
-Sage For Partners
-Sage Active
-Sage Business Cloud Accounting UKI, NA, ZA
-Sage Business Cloud Payroll
-My Sage
-Client Management
-Sage Business Cloud Payroll International
-Sage Sole Trader
Posted Jun 24, 2026 - 11:12 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Accounting ZA, Sage Business Cloud Payroll International), Europe (My Sage, Sage Sole Trader, Sage Active, Sage Business Cloud Accounting (UKI), Sage Business Cloud Payroll International, Sage for Accountants), and North America (Sage Business Cloud Accounting (NA), Sage Business Cloud Payroll International, Sage for Accountants).